.NET CMS
.NET CMS > .NET CMS online support forum > Issues: Open a ticket! > Report any errors

Server Error in '/' Application.

RSS
Author
Date & Time
Message Operations
User Foobar
notdefinite
wikiaspnet@myzeug.de
User123

Installed in https://wiki.mydomain.com gives this error:

Length cannot be less than zero.
Parameter name: length
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentOutOfRangeException: Length cannot be less than zero.
Parameter name: length

Source Error:


Line 1012: Dim Domain As String = Request.ServerVariables("HTTP_HOST")
Line 1013: If Request.Url.Port <> 80 Then
Line 1014: Domain = Domain.Substring(0, Domain.LastIndexOf(":"c))
Line 1015: End If
Line 1016: If AddScheme Then


Source File: C:\wiki\App_Code\Extension.vb Line: 1014


Stack Trace:


[ArgumentOutOfRangeException: Length cannot be less than zero.
Parameter name: length]
System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy) +14122690
WebApplication.Extension.DomainName(HttpRequest Request, Boolean AddScheme) in C:\wiki\App_Code\Extension.vb:1014
WebApplication.Common.CurrentDomain(HttpContext Context) in C:\wiki\App_Code\Common.vb:1099
WebApplication.Config.CurrentDomainConfiguration() in C:\wiki\App_Code\Config.vb:1782
WebApplication.Common.RedirectDomain() in C:\wiki\App_Code\Common.vb:1203
WebApplication.Global.Global_BeginRequest(Object sender, EventArgs e) in C:\wiki\App_Code\global.vb:180
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +80
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.17929
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Maybe your site is online on port 8080?

Try changing the line 1014:

If Request.Url.Port <> 80 AndAlso Request.Url.Port <> 8080 Then

Let me know if this change works!

Andrea Bruno

p.s.:
Pay attention to copy and paste that from this site is not working smile_thinking

Correlated link 500 - Internal Server Error